Installation von .NET Framework unter Windows 8 RTM schlägt fehl

Bei der Installation von Programmen, die .NET Framework 3.5 benötigen, erscheint ein Wizard der die Installation des Pakets vorschlägt. In meinem Fall endete die Installation, die per Windows Update die Dateien nachzieht, mit einem Fehler. Ich vermute das hier unser WSUS-Server das Problem ist, falls man allerdings die Installation auf einem Offline-System durchführen möchte, steht man vor dem gleichen Problem. Hier hilft, wie schon beim Windows Server 2012 Beta, die Installation per DISM:

Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:<Pfad_zum_sxs_Ordner> /LimitAccess

Da das mounten von ISO-Dateien unter Windows 8 ohne Dritthersteller-Programme funktioniert, kann man entweder “mal eben” die CD einlegen oder die ISO-Datei mounten und den Pfad auf den SXS-Ordner lenken (In meinem Fall “F:\sources\sxs”. Mit diesem Befehl funktioniert die Offline-Installation problemlos und .NET Framework 3.5 kann verwendet werden.

DotNetFramework3.5

Teilen:

Jan Kappen

Jan Kappen ist ausgebildeter Fachinformatiker in der Richtung Systemintegration. Er hat seine Ausbildung im Sommer 2008 abgeschlossen und arbeitet seitdem bei der Rachfahl IT-Solutions GmbH & Co. KG. Jan Kappen ist unter anderen MCITP Server Administrator, Enterprise Administrator und Enterprise Messaging Administrator 2010 sowie MCTS für System Center Virtual Machine Manager 2008, Windows Server 2008 Active Directory, Windows Server Virtualization und Windows Server 2008 Network Infrastructure. Im April 2015 wurde Jan Kappen im Bereich "File System Storage" für seine Expertise und seine Community-Arbeit mit dem MVP Award von Microsoft ausgezeichnet.

8 Kommentare:

  1. hi jan,

    ja da bin ich heute auch schon drüber gestolpert. auch lässt sich win8 nicht einfach aktivieren, dafür wird zZ auch noch die cmd benötigt.

    1. cmd als admin
    2. slmgr.vbs -ipk “[KEY]”

    und darüber hinaus fährt der rechner bei aktiviertem usb 3.0 und installierter hyper-v rolle (immer) nicht hoch…kannst du das auch soweit nachvollziehen?

    manuel

  2. Ja kann ich (Aktivierung), die musste ich auch per cmd machen. Hyper-V läuft bei meiner Z200 HP Workstation problemlos, allerdings hat die auch kein USB 3.0. Das mit USB 3.0 können wir an unseren Powerkurs-Maschinen nachvollziehen, die haben zwei Ports. Antwort folgt :)
    Gruß

  3. Bei mir klappt die Installation leider trotzdem nicht.
    CMD wird als Administrator ausgeführt.
    Windows 8 Enterprise RTM ist aktiviert.
    Error-Code: 0x800f081f
    Ich habe einfach die ISO von Windows 8 eingebunden.
    Wo könnte hier noch ein Problem sein?

  4. Hi Michael,
    ich habe die ISO auch einfach nur gemountet, daran kann es eigentlich nicht liegen…
    Schau mal hier, hier gibt es die gleichen Fehler und einige Lösungen:

    http://social.technet.microsoft.com/Forums/en-US/W8ITProPreRel/thread/f4217b5c-4341-4c6a-99be-46a178b34132

    Weiterer Thread:
    http://social.msdn.microsoft.com/Forums/en-US/windowsdeveloperpreviewgeneral/thread/39428e91-7c53-4bce-a8c5-2a995a1f611b/

    Drittes Thema, was ich gefunden habe:
    http://social.msdn.microsoft.com/Forums/en-US/windowsdeveloperpreviewgeneral/thread/670dd964-11cf-4006-96ee-1bf2e16e9979/

    Gruß und viel Erfolg
    Jan

  5. Danke für deine Hilfe, hab es aber jetzt schon geschafft.
    Warum es über den DISM-Befehl nicht geklappt hat, weis ich nicht, allerdings weis ich warum er sie auch nicht über die Windows Updates herunterladen konnte. Der WSUS hat sich immer dazwischen geschaltet, deshalb hab ich die lokalen Gruppenrechtlinien ändern müssen.
    http://support.microsoft.com/kb/2734782

  6. hallo jan,

    hast du schon die hyper-v rolel mit usb 3.0 getestet? konnte das ganze jetzt auf einem 2. und 3. system nachvollziehen…

    grüßte aus txl
    manuel

  7. Hallo Jan,

    ich habe versucht FM3.5 unter Win8 zu aktivieren, so wie du es oben beschrieben hast. (über die DVD). Befehl ist auch richtig eingegeben. Nach 66,2% kommt jedoch die Fehlermeldung, dass die Quelldateien nicht gefunden wurden. Auf der CD sind sie aber drauf und e:\sources\sxs stimmt auch. Hast du noch einen Tipp für mich? Ich bin ziemlicher Laie und komme daher mit den englischen Links erst recht nicht gut klar.

    Viele Grüße, Sylvia

  8. Hallo, das Problem kenne ich, meist liegt es an einer falschen Quelle. Ist das genau die DVD, von der du installiert hast? Wenn nicht nimm bitte einmal die DVD, alternativ kopiere dir den Ordner einmal auf Festplatte und leite auf den lokalen Pfad um…
    Gruß, Jan

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.