PPPoE-Verbindung mit Linksys WRT54GL und DD-WRT

linksys_wrt54gl_ddwrt1Ich stand vor der Aufgabe, einen vorhandenen DSL-Router durch ein Linksys-Gerät mit DD-WRT zu ersetzen, der als DSL-Router und als WLAN Accesspoint genutzt werden soll. Die Vorgehensweise war wie folgt:

  1. Firmware-Update von der Standard-Linksys-Firmware auf DD-WRT v24 SP1 mini
  2. Firmware-Update von DD-WRT v24 SP1 mini auf DD-WRT v24 SP1 generic
  3. Konfiguration des Gerätes
  4. Anschließen des Gerätes an ein DSL-Modem und Neustart des Gerätes

Das wäre der normale Ablauf gewesen, allerdings hat der Router keine WAN-Verbindung aufgebaut. DHCP und alles funktionierte, nur die die PPPoE-Verbindung. Modem gewechselt, Zugangsdaten überprüft, nichts hat das Gerät dazu bewegt sich zu verbinden. Den alten Router wieder angeschlossen, keine Probleme, sofort wieder online.

Lösung des Problems:

Nach dem Firmware-Update MUSS der Linksys-Router hart resetet werden, sonst funktioniert die PPPoE-Anwahl nicht. Das gleiche Problem tritt auch auf bei der Konfiguration einer WLAN-Bridge. Bei Änderung der bestehenden Konfiguration zu einer WLAN-Bridge sieht alles perfekt aus, die Daten passen, nur die Brücke funktioniert nicht. Hier hilft ebenfalls ein Reset und eine erneute Konfiguration. Ich persönlich hatte auch das Problem einer nicht richtig funktionierenden Konfiguration nach dem Sichern der Konfiguration und dem Einspielen der Konfiguration der Konfiguration auf dem GLEICHEN Router (nach einem Reset). Ein erneuter Reset und ein manuelles Einstellen brachte hier ebenfalls eine Lösung.

Die Probleme müssen nicht zwangsläufig ein Problem von DD-WRT sein, und ich möchte die Software auch nicht schlecht reden, denn aus diesem “Phänomen” bin ich äußerst zufrieden mit der Funktionenvielfalt und der Stabilität der Geräte.

Teilen:

Jan Kappen

Jan Kappen ist ausgebildeter Fachinformatiker in der Richtung Systemintegration. Er hat seine Ausbildung im Sommer 2008 abgeschlossen und arbeitet seitdem bei der Rachfahl IT-Solutions GmbH & Co. KG. Jan Kappen ist unter anderen MCITP Server Administrator, Enterprise Administrator und Enterprise Messaging Administrator 2010 sowie MCTS für System Center Virtual Machine Manager 2008, Windows Server 2008 Active Directory, Windows Server Virtualization und Windows Server 2008 Network Infrastructure. Im April 2015 wurde Jan Kappen im Bereich "File System Storage" für seine Expertise und seine Community-Arbeit mit dem MVP Award von Microsoft ausgezeichnet.

7 Kommentare:

  1. Hallo,

    ich habe da einmal eine technische Frage an den Fachmann ?

    Ich habe ein Lancom 1721 für mein Netzwerk, komme prima
    in das Internet, da T-Online der Provider ist.

    Jetzt soll ich von einem Rechner-X mit Internetanschluß
    über LANCom 1721 einen PPPOe True Path einrichten.

    Was ist PPPOe True Path ?, wie funktioniert das ?

    ich möchte gern schlauer werden, Danke.

    mit freundlichen Grüßen

    Frank Bruch

  2. Hallo Frank,
    soll Rechner-X eine eigene Internet-Verbindung aufbauen? Ich kenne die Möglichkeit, das man einem PC in einem lokalen Netzwerk die Möglichkeit geben kann, eine Internetverbindung aufzubauen (durch den Router hinweg bzw. stellvertretend für diesen), das ganze nennt sich “pppoe passthrough”. Evtl. einfach mal bei Google informieren und dann nochmal Bescheid geben, ob es sich um diese Art der Verbindung handelt.

    Gruß Jan

  3. Hallo, bin auf Deinen Post gestossen da ich im MOment absolut genau das selbe Problem habe. Bei mir haut das mit dem Hard Reset aber nicht hin. auch nach dutzenden Versuchen baut der Linksys keine Verbindung auf.

    Keine Ahnung warum , ist auch ein wrt54 gl .

    gruss andreas

  4. Falls du die Zugangsdaten mehrfach falsch eingegeben hast bzw. der Router mehrfach das Kennwort falsch sendet sperrt der Provider ggf. das Konto. Frag dort mal bitte an, ob die Einwahl möglich ist. Alternativ probier manuell eine PPPoE-Verbindung mal um zu gucken, ob die Daten funktionieren…

    Gruß, Jan

  5. Ja super Tipp – Danke!
    Bin fast schon verzweifelt, dachte das PW wäre falsch etc. pp. aber der Tipp hier hat 100% geholfen (nur bei Reset UND neuer Config).

  6. Hallo Jan,

    nur eine kurze Frage zum Hard-Reset: Hast du die Reset-Taste nur 30 Sekunden gehalten, oder hast du einen 30-30-30 reset gemacht (also mit Strom raus und wieder rein)?
    Danke für deine Antwort!

    Gruß Manuel

  7. Hi,

    ich habe einen 30-30-30 Reset gemacht, inkl. Strom raus und rein…

    Gruß, Jan

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.